Real-Time Notifications (WebHooks): IXCloud Webhooks deliver real-time HTTP notifications to your internal systems whenever key call recording events occur
Meeting Summary: introduced support for meeting summary capabilities, including configuration, licensing, and OpenAPI support.
Sentiment Analysis: added sentiment analysis capabilities with support for configuration, licensing, cache/catalogger integration, call details, and shared calls. Expanded search experiences: added search bars for users, targets, profiles within groups, and endpoint-related
workflows.
Playback permission improvements: added “Select All” support for group playback permissions.
Retention profile administration: added “Set As Default” to the context menu for retention profiles.
Version display support: IXCloud can now use the version API to display version information. Filtering and search usability: improved reset behavior, disabled search execution patterns, clear-filter access, redesigned date filtering, and more consistent search bar behavior across modules.
Administration workflows: improved organization pagination, group membership handling, profile selection behavior, target/user selection experiences, and single-select control design.
Shared call experience: improved transcription-sharing behavior when no transcription exists and added shared-call audit coverage.
Audit trail visibility: improved system observability by capturing more admin events across authentication, storage, licensing, roles, profiles, groups, users, targets, and call logs.
Performance enhancements: created additional indexes for meeting fields, GDPR, and evaluation status; improved search performance when assigning licenses to groups.
UI consistency: corrected alignment, color, spacing, wording, spelling, and other visual polish issues across audit trail, AD Sync, playback logs, call deletion logs, permissions, and listing views.
General bug fixes
Posted Aug 12, 2026 - 12:26 EDT
Completed
The scheduled maintenance has been completed.
Posted Aug 07, 2026 - 15:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 07, 2026 - 14:00 EDT
Scheduled
We will be undergoing platform update maintenance at this time. No down-time anticipated.
Posted Aug 06, 2026 - 09:40 EDT
This scheduled maintenance affected: APIs (United Kingdom) and IXCloud Portal (UK South).