Microsoft Single Sign On Degraded
Incident Report for IXCloud
Resolved
This incident has been resolved and Single Sign on is operational.
Posted Mar 05, 2024 - 21:43 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 04, 2024 - 10:26 EST
This incident affected: IXCloud Portal (Australia East, UK South, Germany West Central, South Africa North).