Recording Bots Showing in Teams Meetings

Incident Report for IXCloud

Resolved

Microsoft has found and resolved the issue. Please let us know if you have any issues.
Posted Nov 18, 2025 - 04:34 EST

Investigating

Recorded Teams users with Enterprise Teams licenses may have recently noticed that the recording bots have started to show up in meetings. Our engineering team has engaged with Microsoft to get this resolved and we'll update this page as we progress.
Posted Nov 17, 2025 - 09:39 EST
This incident affected: Microsoft Teams Recorders (United States, Germany, Australia, Canada, United Kingdom, Singapore, South Africa North).